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All Creative Designs 
HTML Web Tutorial for PC  
Using KompoZer  
Updated Version 12 June 2010 
 
Step 1 Download and Install KompoZer 
Step by step instructions to build your first web page using KompoZer web editor. 
 
Easy web authoring  
KompoZer is a complete web authoring system that combines web file management and easy-
to-use WYSIWYG (What You See Is What You Get) web page editing. KompoZer is designed to 
be extremely easy to use, making it ideal for non-technical computer users who want to create 
an attractive, professional-looking web site. (Source: kompozer.net/features) 
 
First create a folder and name it webeditor or kompozer in your My Documents Folder. 
If you a viewing the PDF version you might have to type or copy and paste address into your browser. 
Than Go To http://www.kompozer.net/download.php  Control click in MS word Version 
For Windows operating system select version: 0.7.10 and click download (Figure 1) 
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Figure 1 

Figure 2 

If download does not start click here 
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In the File Download Box (Figure 2) Click Save > Navigate to the folder you created 
(Figure 3) and save the installation files into this folder. After completed download 
Locate \kompozer-0.7.10-win32.zip and follow instructions to unzip files, by default 
unzipped files are saved into the same root folder (Figure 3).  

To create a Short Cut Icon on your Desktop first: Right click Mozilla Icon > Send To > 
Desktop (create shortcut). (Figure 4 a) 
 

 
  
Double click Kompozer Mozilla icon (Figure 4), (If security warning appears click run) 
and Kompozer interface will open. 
(Figure 5) 
 

 
 
 

Kompozer Interface 
Read through the help tips 
or click close. 

Figure 3 Figure 4 

Figure 5 

Zipped Folder 

Figure 4 a 
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Step 2 Opening an existing HTML document in Kompozer 
 
Open the index file we have created in the basic HTML tutorial. 
(See Step 1 and 5 in Basic HTML Tutorial Part 1) (Figure 6) 
 

 
 
In Kompozer’s top menu bar click Open File and navigate to your my_first_webpage 
folder, select index.html and click open. (Figure 7) 
 
 

 
 
Follow the same steps to open any HTML file in KompoZer stored on your 
computer. 
 
 
If you have completed our Basic HTML tutorials read next page, otherwise go to step 3, 
Saving a new HTML document. 
 
Next page contains information on how to toggle between different views. (Figure 8 a)

Figure 6 

Figure 7 
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The web page we built in basic HTML tutorial 1 opens in KompoZer. (Figure 8 a) 
Use the toggle buttons and check and compare your source view. (Figure 8 b) 
 
  

 
 

Figure 8 a 

Figure 8b 
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Kompozer did add a few extra tags to your index file the <tbody> table body tag 
appeared in line 8 
and the closing </tbody> table body tag in line 19 wrapping all rows within your table 
tags. 
These tags are not necessary to display your web page correctly. 
Line 1 adds information about the html document version. 
 
The HTML toggle button will show tag information and can be helpful to understand 
table layout structure, but does not show table rows. 
 
Follow the same steps to open any HTML file in Kompozer 
 

Step 3 saving a new HTML document 
 
Open My Computer and create a folder in My Documents called local_sites, in this folder 
create a new folder and name it my_web_site or any term making sense to you, but 
remember no spaces in folder names. 
(See Step 1 and 5 in Basic HTML Tutorial Part 1 for more information on creating a 
folder structure for your web projects.) 
Kompozer will create a blank document by default when starting the application. 
 
In Menu bar Select File > Save and then type the title for your home page, here you can 
use spaces, we call our example My Home Page. This title will be shown in the top of 
any internet browser. 
See figure 9 for explanation and location of Menu Bar, Tool bar and formatting tool bars. 

   
 
 

Figure 9 

1. Click Save under File in Menu Bar 

2. Type Page Title and click OK 
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Save Page As window appears under Save in: navigate to your root folder. 
(in this example called my_web_site) 
Change the file name to index.html or just index as KompoZer will add file extension 
automatically and click save. (Figure 10) 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Navigate to your web folder 

Figure 10 
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Step 4 Creating a Banner 
 
A. Insert a table 
To insert a table into the body of your web page click the TABLE button on toolbar. 
Insert Table window appears, click on the Precisely Tab and enter 1 under Rows and 1 
under columns. Under Width type 900 and select pixels in the drop-down menu. 
Leave the border setting at 1 if you desire a border or change to 0 for no border. 
Click OK. (Figure 11 a) 

 
Click within newly created table on the interface and then click the Table button on the 
toolbar again. (Figure 11 b) 
 

 
 
Table Properties Box opens under the Cells Tab. Tick the box for Horizontal and select 
Center (1). Click on the Table Tab (2). 
 

 
 
 
 
 
 
 
 

Figure 11 a 

Figure 11 b 

Figure 12 
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Under Table Tab change values for Spacing and Padding to 0 
For Table Alignment select Center. 
Click OK (Figure 13) 
 

 
 
B. Saving a banner image 
 
We will insert a banner background using a CSS class style and a headline containing 
information about your web page into the table we created. 
 
Saving a background image for your banner 
 
Go to our web site > Gallery > Backgrounds Page 3 or control click link below: 
http://www.allcreativedesigns.com.au/pages/gallbackgrounds3.html 
If you a viewing the PDF version you might have to copy and paste address into internet browser 
 
Choose a banner background image and left click on it to view the enlarged image. 
Right click the enlarged image and select Save Picture As… 
Navigate to your web folder containing your index.html file and click Save.  
(Figure 14 Next Page) 
 
If you like save a copy of your own banner background image into your web folder 
containing your index.html file. 
To use your own background image make sure it is 900 pixels wide by 150 pixels high 
(or between 120 to 200 pixels high depending on your requirement) and it is web 
optimized to a file size below 100 KB. See our Picasa Image Editing Tutorial (Freeware 
by Google) on how to crop and web optimize your own images. 
Only JPG, GIF and PNG image file formats will work! 
 
 
 
 
 

Figure 13 
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Please note: All images on the All Creative Designs website are copyright and only to be 
used for study or private non business purposes. See copyright statement and more 
information on the All Creative Designs website at: 
http://www.allcreativedesigns.com.au/pages/acdCopyrights.html 
If you a viewing the PDF version you might have to copy and paste addresses into your browser. 
 
C. Inserting background image into table using CSS (Cascading Style Sheets) 
In the Kompozer interface under normal view select the table by clicking on it and then 
click the CSS editor button in toolbar (Figure 15 a), Style sheets dialog box appears. 
Select style applied to all elements of class. Type a name for your style; remember no 
spaces in style names and click create style. Do not click OK yet! (See Figure 15 b) 
 

 
Continue reading next page. 

Click CSS Editor 

Figure 14 

Figure 15 a 

Figure 15 b 

Do not click OK  

Tick Style applied to all elements of class 
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In the dialog box select the .mybanner style (1) and click on the background tab (2). 
Under the background tab click choose file (3) and navigate to your web folder (4) and 
open your banner image (5). (Figure 16) 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 16 
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In the CSS Stylesheets dialog box under the background tab select don’t tile from the 
drop-down menu (1). Deselect the Image scrolls (2) and select Center and Top under 
Positioning (3). Click on the Box Tab (4) and type 900px for width and 150px for height 
(5). Now click OK. 
(Figure 17) 

 
 
D.  Applying your Style 
Select your table by clicking on it (1) and then on the Formatting Toolbar select 
mybanner style from the drop-down list (2). Background image will appear. Save your 
web page by clicking save under the File menu in top menu bar or use Save button in 
toolbar. (Figure 18) 
 

 

Background Tab 

Box Tab 

Figure 17 

Figure 18 
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If Background Image does not appear 
To delete style and start again, if CSS style is not working or you made a mistake: 
(Click CSS Button on Tool Bar if CSS Styles window is not showing) 
Select your style (1) and click the Red Cross Delete Button (2). To start again click the 
CSS palette button (3).  
Make sure you are navigating to the right folder containing index and image files under Choose Files  
 

 
 
 
 
 
E. Adding a Heading 
 
Click in your table and type a heading, select your heading (click and drag) (1). To apply 
a heading format select Heading 1 in Formatting Toolbar (2). 
(Figure 19) 
 
 

 
 
 
 
 
 
 
 
 
 

Figure 19 
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F. Other Options 
 
Select your heading. 
On the toolbar under variable width select a font style, but note only Times Roman, Arial 
and Verdana will display correctly in most internet browsers. Change your font color by 
clicking Choose Text Color button. Click small or large A to enlarge or reduce size, 
B to turn heading bold, I for italics or U for underline. 
Save your web page by clicking save under the File menu in top menu bar or use Save 
button in toolbar. (Figure 20) 
 
 

 
 

Figure 20 

Formatting Options 

Save 
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Viewing your web page 
 
To get a preview of your web page as it should look in an internet browser click Preview 
in the Kompozer interface. Click Normal Tab to return to working mode.(Figure 21 a) 

 
 
 
To view your web page in an internet browser like Windows Explorer or Firefox 
Save your web page by clicking save under the File menu in top menu bar or use Save 
button in toolbar. 
Click Browse on Toolbar (1), click Launch Application if window appears, web page 
should open in your default internet browser (2). (Figure 21 b) 
 

 
 
 
Alternative 
In windows explorer (My Computer) navigate to your my_first_webpage folder and 
double left click your index.html file. Your web page should open in your default web 
browser i.e. Internet Explorer or Mozilla Fire Fox. 
 
 
 
 
 
 

Figure 21 a 

Figure 21 b 

Normal Mode 
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Step 5 Adding a Content Table 
 
In this step we will add a table to insert text, images and links. 
 
Insert a row below your banner. Click in banner away from heading. 
Click Table in Menu Bar select and click Row Below. (Figure 22) 
 

Figure 22 
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Insert new table for content 
 
Click in your new row and then click Insert > Table on Menu Bar (Do not use Table 
Button on Tool Bar). In Insert Table dialog box select the Precisely Tab and enter 1 
under Rows and 3 for Columns, set the Width to 100 and select % of cell. Click OK. 
(Figure 23) 
 

 
 
 
 
Click within new table and then click the Table button on the Toolbar. (Figure 24) 
 

 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 23 

Figure 24 
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Under Table Tab (1) change values for Spacing and Padding to 0. 
Leave other settings as they are. Click OK (3) 
 (Figure 25) 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 25 
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Setting cell width 
 
Click in first cell of your new table and click the Table Button on Tool Bar (1). 
Table Properties dialog box appears. Make sure the Cell Tab is selected and tick the 
width box and enter 120 under pixels (2).  Set Content Alignment to vertical Top and 
horizontal Center. Click Apply and then Next to select second cell. (Do not click OK) 
Tick width box and enter 600 for second cell then set Content Alignment as before (3). 
Click Apply and then Next to select third cell, tick width box and enter 180 for third cell 
then set Content Alignment as before (4). 
Click Apply then OK. (Figure 26) 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 26 
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Add E-mail link 
 
Click in the first cell and type Contact Us, click and drag to select. 
Click Link button on tool bar, type your e-mail address and tick box below it. 
Click OK. 
Save your web page by clicking save under the File menu in top menu bar or use Save 
button in toolbar. (Figure 27) 

Click Browse to view your web page in an internet browser and try out your e-mail link. 
 
 
Add Link to other web site 
Click behind the Contact Us link, press enter on your keyboard then type Google 
and select. Click Link button and in the dialog box type http://www.google.com.au 
Under Target tick box and select in a new window to open Google website in new 
browser window and click OK. 
Link to any website in this way. (Figure 28) 
 

 
Save your web page by clicking save under the File menu in top menu bar or use Save 
button in toolbar. 
 

Figure 27 

Figure 28 
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Adding text to your web page 
 
Click in center cell. 
Type text information relevant to your web page. Select any part of text and change font 
size, style and color as described under Add Heading and Other Options. (Figure 29) 
 

 
 
 
If you like to copy and paste text into your web page don’t copy straight from a word 
processor like MS Word. Copy your text from the word document and paste it into 
Notepad, copy it from there again and paste into your web page by clicking in cell where 
text is to be placed then right click and choose paste. 
Find Notepad under All Programs > Accessories on your computer. (Figure 30) 
 

 
 
Save your web page by clicking save under the File menu in top menu bar or use Save 
button in toolbar. 
 
 
 

Figure 29 

Figure 30 
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Insert an image into your web page 
 
Saving an image for your web page 
 
Go to our web site > Gallery > Animals or control click link below: 
http://www.allcreativedesigns.com.au/pages/gallanimals_amphibians.html 
or any other Gallery Page. 
Right click any small image and select Save Picture As, navigate to your web folder 
containing your index.html file and click Save. (Figure 31) 
 
Please note: All images on the All Creative Designs website are copyright, watermarked 
and only to be used for study or private non business purposes. See copyright 
statement and more information on the All Creative Designs website at: 
http://www.allcreativedesigns.com.au/pages/acdCopyrights.html 
If you a viewing the PDF version you might have type or copy and paste address into your browser. 
 
Please contact us if you want to use our images on your commercial website: 
Email All Creative Designs   
enquiries@allcreativedesigns.com.au 
If you a viewing the PDF version you might have to type or copy and paste email address into mail client. 
 

 
 
See our Picasa Image editing tutorial for editing and web optimizing your own images. 
Own images should be no larger than 150 pixels wide by 113 pixels high for this 
purpose and be web optimized. 
 
 
 
 
 

Figure 31 
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Inserting the image 
 
 
 
Click in right hand cell (1). 
Click the Image Button in the Tool Bar (2) and the Image Property Box will open.  
Click the choose file button (3)  
Under Look in: navigate to your web folder, there select your image and click Open (4).  
Add an image description under Alternate Text. (Spaces and capitals allowed) 
Click OK in the Image Property Box. (Figure 32) 
 
 

 
 
 
Save your web page by clicking save under the File menu in top menu bar or use Save 
button in toolbar. 
 
Inserting a second image 
 
Follow steps above and save another thumbnail image into your web folder. 
Click on right hand side of first inserted image and press enter on your keyboard. Click 
image button and repeat the process. 
Save your web page by clicking save under the File menu in top menu bar or use Save 
button in toolbar. 
 
Image resizing and web optimization of your own images is explained in our image 
editing tutorials. (See links at end of tutorial) 
 
 
 
 

Figure 32 
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Add background color to cells 
 
Click in cell with the inserted images (on white space not images themselves) and then 
click the Table button in the tool bar. 
Table Properties box opens under Cells tab click button right next to Background Color. 
Select a cell background color suiting your design and click Apply, try out different color 
and click Apply, when suited click OK. 
(Figure 33) 
 

 
 
 
You might like to repeat the process for other cells. 
 
Save your web page by clicking save under the File menu in top menu bar or use Save 
button in toolbar. 
 
View your web page 
 
Click Browse in Tool Bar or: 
In My Computer navigate to your my_first_webpage folder and double left click your 
index.html file. Your web page should open in your default web browser i.e. Internet 
Explorer or Mozilla Fire Fox. 
 
 
 
Your finished page should look similar to this. (See next page) 
 
 
 

Figure 33 
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Other tutorials available from www.allcreativedesigns.com.au  
You might have to type or copy and paste this address into your browser if viewing the PDF version 
 
www.allcreativedesigns.com.au/pages/tutorialbasicp1.html 
HTML Web Page Tutorial using Notepad, PDF Download Page Part 1 
 
www.allcreativedesigns.com.au/pages/tutorialbasicp2.html 
HTML Web Page Tutorial using Notepad, PDF Download Page Part 2 
 
www.allcreativedesigns.com.au/pages/tutorialbasicp3.html 
Free PDF HTML Tag Tutorial using Notepad, Download Page Part 3 
 
www.allcreativedesigns.com.au/pages/webtutorialkompozer.html 
Web Design Tutorial using KompoZer, PDF Download Page 
 
www.allcreativedesigns.com.au/pages/tutorialpicasa.html 
Picasa Photo Editing Tutorial, Free PDF Download Page 
 
www.allcreativedesigns.com.au/pages/tutorialseo.html 
SEO Tutorial Basic Search Engine Optimization PDF Download Page 
 
Trouble Shooting 
 
My images will not show if: 
 
1. Images are not saved in the same folder as your index.html file 
2. Spelling mistakes or spaces in file names  
3. Wrong file extension i.e. .jpg instead of .gif 
4. Copied file names from MS Word 
 
Please contact us if you like to comment on this tutorial: 
Email All Creative Designs   enquiries@allcreativedesigns.com.au 
If you a viewing the PDF version you might have to copy and paste email address into your mail client. 
 
Please consider a donation to www.kompozer.net   

X 


